打开许久没用的PHPStorm,提示PHP文件里的“Group Use”语法在PHP7中才可用。尝试进设置里更改PHP语法版本,发现熟悉的下拉框不可选。虽然不影响使用,但作为强迫症患者,项目中的一条条红线不解决掉是不能安心写代码的。

软件启动时提示有更新,寻思是不是升级一下就好了?从官网下载升级包安装,打开项目问题依旧。

升级不能解决问题,看来另有原因。上Google查找原因,在JetBrains的官方论坛中找到原因:composer.json中设置了PHP的版本。

原因已经找到,解决方法就看个人发挥。解决办法主要有以下几种:

在composer.json中更改语言版本,例如”php”: “>=5.4.0″改成”php”: “>=7.1.0” ;

2,在”Settings/Preferences | Languages & Frameworks | PHP | Composer”中取消自动与composer同步(Synchronize IDE Settings with composer.json);

删除composer.json文件。不推荐此用法,会导致第三方依赖库不能下载,失去自动补全功能;

使用旧版的PhpStorm。论坛反馈和本人亲身体验,旧版不会读取composer.json文件锁定语言版本,升级到2018.1版本中才会无法更改语法版本。